Operating System requirements (Mac)

The Paltalk application works on OSX versions 10.9 or higher.

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.